Sublime Text安装与基本配置

Published on 2015-01-31
----- BEGIN LICENSE -----
Andrew Weber
Single User License
EA7E-855605
813A03DD 5E4AD9E6 6C0EEB94 BC99798F
942194A6 02396E98 E62C9979 4BB979FE
91424C9D A45400BF F6747D88 2FB88078
90F5CC94 1CDC92DC 8457107A F151657B
1D22E383 A997F016 42397640 33F41CFC
E1D0AE85 A0BBD039 0E9C8D55 E1B89D5D
5CDB7036 E56DE1C0 EFCC0840 650CD3A6
B98FC99C 8FAC73EE D2B95564 DF450523
------ END LICENSE ------

基础插件

安装Package Control

  1. 下载Package Control
  2. 打开Sublime Text,点击Preferences | Browse Packages...
  3. 向上一层,找到Installed Packages并进入;Linux下这个目录一般在~/.config/sublime-text-3/Installed Packages中
  4. 把刚刚下载的文件放到这里
  5. 重启Sublime Text

有参考价值的文章

Linux下中文输入的支持

参考sublime-text-imfix,该小程序会先尝试安装subl和fcitx,如果之前没有安装的话。

如果重新登录之后切换输入法比较麻烦(不能使用shift切换)可以

  1. 点击任务栏右上角的键盘图案,选择“配置”,然后把多余的都删掉,只留下“拼音”和“键盘 - 英语(美国)”两项。这时通过手动选择就已经可以输入中文了。
  2. 还是在这个对话框,选择“全局配置”选项卡,点击“切换激活/非激活输入法”旁边的第一个按钮,然后按shift。这是就可以使用shift切换输入法了!
  3. 遗憾的是只有通过终端输入subl启动才能在Sublime中输入中文。不过已经可以使用了!
  4. 按下Ctrl+Shift+P调出命令面板,输入install调出Install Package选项并回车,输入IMESupport,选中并安装

Less支持

参考这篇文章,下边只起备份的作用,同时提炼了最主要的步骤。

Windows下的less

  1. 下载less.js-windows
  2. 解压到安装目录,如D:\less
  3. 将安装目录添加到环境变量Path中
  4. 进入命令提示符,输入lessc,如果打印出less使用方法,则安装成功

Linux下安装less

sudo apt-get install nodejs-legacy npm
sudo npm install less -gd

安装Less2Css插件

安装Less2Css插件

  1. 按下Ctrl+Shift+P调出命令面板
  2. 输入install调出Install Package选项并回车
  3. 输入less2css,选中并安装
  4. 用同样的方法再安装Less以支持语法高亮

Linux下一些问题的解决

编译less的时候不停地弹出一个提示框“the compress option has been deprecated...”,很烦人,参考了这个Issue的解决,可以这么做

  1. Install less-plugin-clean-css

    sudo npm install -g less-plugin-clean-css
  2. 然后找到Less2Css.sublime-package的位置,一般在~/.config/sublime-text-3/Installed Packages中,复制出来

    cp ~/.config/sublime-text-3/Installed\ Packages/Less2Css.sublime-package ~/
  3. 用归档管理器打开Less2Css.sublime-package,找到lesscompiler.py,修改第184行为

    cmd = [lessc_command, less, css, "--clean-css", "--verbose"]
  4. 保存并替换Less2Css.sublime-package中的这个文件,然后再拷回去

    cp ~/Less2Css.sublime-package ~/.config/sublime-text-3/Installed\ Packages/

测试

新建一个less文件,随意输入一些样式,保存,即可生成对应的css文件。

如果发生了less2css error:[Error 2],则说明还需要重启。

配置

// linux下的等宽字体
"font_face": "DejaVu Sans Mono",
"font_size": 10,
//tab自动转为空格
"translate_tabs_to_spaces": true,